Your browser does not fully support modern features. Please upgrade for a smoother experience.
Submitted Successfully!
Thank you for your contribution! You can also upload a video entry or images related to this topic. For video creation, please contact our Academic Video Service.
Version Summary Created by Modification Content Size Created at Operation
1 handwiki Rita Xu -- 1081 2022-10-28 01:30:51

Video Upload Options

We provide professional Academic Video Service to translate complex research into visually appealing presentations. Would you like to try it?
Cite
If you have any further questions, please contact Encyclopedia Editorial Office.
HandWiki. Name Server. Encyclopedia. Available online: https://encyclopedia.pub/entry/32085 (accessed on 15 October 2026).
HandWiki. Name Server. Encyclopedia. Available at: https://encyclopedia.pub/entry/32085. Accessed October 15, 2026.
HandWiki. "Name Server" Encyclopedia, https://encyclopedia.pub/entry/32085 (accessed October 15, 2026).
HandWiki. (2022, October 31). Name Server. In Encyclopedia. https://encyclopedia.pub/entry/32085
HandWiki. "Name Server." Encyclopedia. Web. 31 October, 2022.
Name Server
Edit

A name server is a computer application that implements a network service for providing responses to queries against a directory service. It translates an often humanly meaningful, text-based identifier to a system-internal, often numeric identification or addressing component. This service is performed by the server in response to a service protocol request. An example of a name server is the server component of the Domain Name System (DNS), one of the two principal namespaces of the Internet. The most important function of DNS servers is the translation (resolution) of human-memorable domain names and hostnames into the corresponding numeric Internet Protocol (IP) addresses, the second principal name space of the Internet which is used to identify and locate computer systems and resources on the Internet.

computer application network service domain names

References

  1. RFC 1034, Domain Names—Concepts and Facilities, P. Mockapetris, The Internet Society (November 1987)
  2. RFC 781, Internet Protocol—DARPA Internet Program Protocol Specification, Information Sciences Institute, J. Postel (Ed.), The Internet Society (September 1981)
  3. RFC 1035, Domain Names — Implementation and Specification, P. Mockapetris, The Internet Society (November 1987)
  4. Paul Hoffman; Andrew Sullivan; Kazunori Fujiwara (January 2019), DNS Terminology, IETF, BCP 219, https://tools.ietf.org/html/bcp219, retrieved 17 December 2015 
  5. Yakov Rekhter; Susan Thomson; Jim Bound; Paul Vixie (April 1007), Dynamic Updates in the Domain Name System (DNS Update), IETF, doi:10.17487/RFC2136, RFC 2136, https://tools.ietf.org/html/rfc2136, retrieved 17 December 2015 
  6. Robert Elz; Randy Bush (July 1997), Clarifications to the DNS Specification, IETF, doi:10.17487/RFC2181, RFC 2181, https://tools.ietf.org/html/rfc2181, retrieved 17 December 2015 
  7. "Name Server definition at techterms.com". http://www.techterms.com/definition/nameserver. 
  8. Paul Mockapetris (November 1987), Domain Names - Domain Concepts and Facilities, IETF, sec. 4.2.1, doi:10.17487/RFC1034, RFC 1034, https://tools.ietf.org/html/rfc1034, retrieved 17 December 2015 
  9. "Composite Application Manager for Internet Service Monitoring, Reference Guide". IBM. http://www-01.ibm.com/support/docview.wss?uid=pub1sc23881400. Retrieved 15 February 2012. 
  10. "Network setup for Cambridge's new DNS servers" (in en). https://fanf.livejournal.com/133020.html. "The recursive DNS server (aka recdns)" 
  11. , though this is typically not used for caching DNS names. Nemeth, Evi; Snyder, Garth; Hein, Trent R. (2006). Linux administration handbook (2 ed.). Addison-Wesley Professional. p. 504e. ISBN 978-0-13-148004-9. //books.google.com/books?id=GB_O89fnz_sC. Retrieved 2012-02-14. "ncsd [.....] cache[s] the results of DNS lookups [...] but it also wraps the library routines that access information from the passwd and group files and their network database equivalents." 
More
Upload a video for this entry
Information
Contributor MDPI registered users' name will be linked to their SciProfiles pages. To register with us, please refer to https://encyclopedia.pub/register :
View Times: 681
Entry Collection: HandWiki
Revision: 1 time (View History)
Update Date: 31 Oct 2022
Notice
You are not a member of the advisory board for this topic. If you want to update advisory board member profile, please contact office@encyclopedia.pub.
OK
Confirm
Only members of the Encyclopedia advisory board for this topic are allowed to note entries. Would you like to become an advisory board member of the Encyclopedia?
Yes
No
${ textCharacter }/${ maxCharacter }
Submit
Cancel
There is no comment~
${ textCharacter }/${ maxCharacter }
Submit
Cancel
${ selectedItem.replyTextCharacter }/${ selectedItem.replyMaxCharacter }
Submit
Cancel
Confirm
Are you sure to Delete?
Yes No
Academic Video Service